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Creating and Manipulating the Corridor 
This course is for the 2021 Release 1 version of:

OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos for 

this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to any 
section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can 
also submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter 
experts are available to help.

Course Level: Fundamental

http://learn.bentley.com
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Course Overview

In this course, you will create a corridor model and then explore the many tools and techniques to edit and manipulate the corridor. We will 
take a look at how to add multiple templates drops along the corridor as you encounter intersections, driveways and turn lanes and how to edit 
and copy template drops in lieu of creating a new template. 

We will show how to make the corridor follow edge of pavement geometry using point controls and corridor references. You will learn how the 
secondary alignment tool aids in changing the direction of template processing as it applies to point controls and corridor reference elements. 

You will also learn how to use parametric constraints to override default template values for pavement depths, curb heights, shoulder slopes 
and ditch widths and how to use the clipping reference tool to clip out a portion of your corridor. 

We will take a look at how corridors interact with other corridors by learning how to use target aliasing to seek corridors. And finally we will 
show how to create end condition exceptions in areas that require a different type of end condition solution.

Skills Taught
 Corridor Creation 

 Multiple Template Drops

 Edit Template Drops

 Copy Template Drop

 Key Stations

 Corridor References

 Secondary Alignment

 Point Controls

 Create Parametric Constraints

 Clipping References

 Target Aliasing

 End Condition Exceptions
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Corridor Modeling Overview

Corridor Modeling allows the user to create a dynamic, intelligent and powerful 3D model of their design. The 3D model is then used to 
create cross sections, terrain models and generate corridor quantities. A corridor is created first in 2D by assigning a horizontal and 
vertical alignment to the corridor and then assigning a template to the corridor at a defined interval along the horizontal alignment. 
Once the template is assigned to the corridor a 3D model is created. 

A template represents the transverse geometry or typical section along the corridor. Templates are made up of points and components 
and are stored in an template library. When a corridor is processed the template points create 3D linear features (edge of pavement, 
shoulder, curb, sidewalk, cut/fill lines etc.) along the corridor and the template components create the 3D material meshes (i.e. 
pavement, shoulder, curb & gutter, sidewalk, side slope grading etc.) along the corridor.
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Project Overview

In this course you will be creating a corridor model for London 
Rd. which is a simple 2 lane road with a center turn lane that 
passes under the S.R. 97 highway. The London Rd. Corridor 
features two dedicated right turn lanes on part of the project as 
well as multiple intersections, driveways and bridge abutment 
walls. 

As you progress through this course we will show how flexible 
and easy it is to create, edit and manipulate a corridor model 
with the Corridor Modeling tools.
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Exercise 1: Create the Corridor and Template Drops

Description
In this exercise, you will learn how to create a corridor for London Rd. and select a feature definition to control the display and accuracy 
of the corridor. You will also learn how to assign multiple template drops to the corridor and how to use corridor reference elements.

Skills Taught
 Create London Rd. Corridor

 Assign Corridor Feature Definition

 Assign Multiple Template Drops

 Add Corridor Reference
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Start OpenRoads Designer 

In this section, you will start OpenRoads Designer and set the proper workspace. When working with OpenRoads Designer Corridor 
Modeling always start in 2D.

1. Start the software.

2. Set the WorkSpace and WorkSet

The WorkSpace and WorkSet define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

a. Select Training and Examples from the WorkSpace menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet menu.
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Open the Corridor and Review Attached Reference Files

Corridor creation always starts in 2D and requires horizontal geometry, vertical geometry and a template as a starting point. You will 
typically need an existing terrain model (i.e. existing ground surface) to tie down slopes. You may also need other items such as 
edge of pavement geometry and other corridors. 

Before we begin creating a corridor, lets take a look at the corridor design file and the reference files that have been attached for your use as 
you progress through this course. The ability to reference civil data such as terrain, geometry, superelevation and corridors is an extremely 
powerful and fundamental workflow of OpenRoads Designer since all civil data is stored in a dgn file.

1. Open Corridor-LondonRd.dgn [Metric-Corridor-LondonRd.dgn].

2. Click anywhere in View 1 to make it active. View 1 is 2D and View 2 is 3D.

3. Select Home > Primary > Attach Tools > References

4. Review the attached reference files. A brief description of each is included on the next page.

5. Close the References dialog.
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Reference File Descriptions:

Terrain_Exising.dgn - Existing ground terrain model, this will be the active terrain model used for this course.

Geometry.dgn - Roadway centerline horizontal and vertical geometry

Geometry-Control.dgn - Roadway plan geometry (edge of pavement, shoulder, curb, sidewalk, etc.) and corridor clipping shapes

Geometry-ROW.dgn - Right of Way lines (used to display on cross sections)

Superelevation-LondonRd.dgn - Superelevation data for London Rd.

Corridor-SR97.dgn - S.R. 97 highway corridor model

Corridor-Bridge.dgn - S.R. 97 bridge model

Corridor-AbutmentWalls.dgn - S.R. 97 bridge abutment walls model

When corridors are created they are “ruled” or associated to the horizontal and vertical geometry. This is a very powerful feature because if 
the horizontal and vertical geometry change the corridor will update itself automatically. Also, when assigning civil data such as civil geometry 
and superelevation to a corridor it is also “ruled” or associated to the corridor. It’s very important to be aware of which reference files are used 
and “ruled” to the corridor. Detaching reference files can break these rules and associations. If you try to detach a reference file that is ruled to 
the corridor a warning message will appear.

Note how the files are federated and named. It is a best practice to keep your files federated and named in an organized manner. Doing so will 
eliminate problems downstream. Generally, it is a best practice to put all individual centerline horizontal and vertical geometry, Corridors and 
Superelevation into individual DGN files. For example, the centerline horizontal and vertical geometry for S.R. 97 would be placed into 
Geometry-SR97.DGN, the Corridor for S.R. 97 would reside in Corridor-SR97.DGN and the superelevation for S.R. 97 would be in Super-
SR97.DGN.
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Create the Corridor and Add Rural Template Drop

In this section you will create a new corridor for London Rd. and create a 2 Lane + Turn Lane Rural Template Drop 
along one section of the corridor and then add a 2 Lane + Turn Lane Urban Template Drop along another section of the 
corridor.

1. Open the Template Library

a. Select Corridors > Template > Create Template to open the create template tool.

b. Select File > Open in the template library window and select the LondonRd-Imperial.itl [LondonRd-
Metric.itl].

c. Close the Create Template window.

2. Click anywhere in View 1 to make it active.

3. From the ribbon menu select Corridors > New Corridor

a. Set the Feature Definition to Conceptual

Feature Definitions for Corridors, control the accuracy and display settings of the Corridor 3D model 
(See Appendix A for more information on Corridor Feature Definitions). 

b. Select the London Rd. centerline geometry

c. Right-click to accept the active profile.

d. Left-click to accept the corridor name LondonRd and create the corridor.

Notice a closed shape is now drawn along the alignment in the 2D view, this is referred to as the Corridor 
Object. 

Once the Corridor is created the Create Template Drop tool will appear automatically and the heads-up 
display will be prompting you to select a template. The Create Template Drop tool is used to assign a 
template(s) to the corridor at a defined interval along the roadway alignment. 
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In the following steps, you will create multiple template drops along the corridor. You’ll first add a 2 Lane + Turn Lane Rural Template Drop 
and then you will add a 2 Lane + Turn Lane Urban Template Drop.

4. Press the <ALT><Down Arrow> to open the Template Library: LondonRd-Imperial.itl [LondonRd-Metric.itl]

5. Browse to Project Templates and select 2 Lanes + Turn Lane - Rural

6. Left-click OK to accept the template.

7. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Start Station: Press ALT to lock to Start

 End Station: Snap to the End Rural Template Drop line in the 2D view (If AccuSnap does not work, use a tentative snap by 
pressing the left and right (or center) mouse button at the same time. Which mouse buttons to use depends on how the machine is 
setup).

 Drop Interval: 10 [3]

The template drop has been assigned and the Corridor Model is now created. 

Note, that when you snap to a line (or any element) in a design file to establish the start/end station of your template drop, the software 
will remember that you snapped to that line because of the rules and relationships and design intent that is built into the software. If you 
move the line the template drop start/end station will update automatically.

It’s important to know that there are 2 essential parts to a corridor, the Corridor Object and the Corridor Model. 
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The Corridor Object is a 2D closed shape with perpendicular handles along its edge making it easy to identify and select. This shape 
stores all of the data entered when the corridor is created. The shape is stored in the 2D model named Default and is a Construction 
Class element so its display can temporarily be turned off when desired.

The Corridor Model is made up of 3D elements and components that are automatically created in a 3D model named Default-3D when 
the corridor is processed. The 3D model is automatically referenced to the 2D model but the 3D reference display can be turned on or off 
as needed. Also, the Default-3D model should never be created or edited manually or the corridor will not function properly. Always let 
OpenRoads Designer create and manage the 3D Model.

The Corridor Object is always created in the Default 2D model (View 1) and the Corridor Model is created automatically in the Default 3D 
model (View 2). 

Since the 3D model is automatically referenced to the 2D model we want to turn it off for clarity purposes.
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8. Turn off the display of the 3D model reference in the 2D view.

a. Select Home > Primary > Attach Tools > References

b. Select the Corridor-LondonRd.dgn [Metric-Corridor-LondonRd] Notice the Default-3D name in the model column.

c. Click the Display Reference icon at the bottom of the window to turn off the file.

d. Close the References window.
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Review the Corridor in 2D and 3D 

In View 1 notice there is a shape that is drawn along the corridor, this is the Corridor 
Object. 

1. Review Corridor Properties.

a. Select the Element Selection tool.

b. To access the corridor properties, select the Corridor Object.

c. Hover your cursor over the corridor object or corridor handle for a few seconds. 
A context sensitive toolbar will appear, giving you access to other corridor 
tools.

d. Select the Corridor Properties icon on the toolbar to review the properties of 
the corridor.

Note that the Use Active Profile is set to True. That means the corridor will use 
the active profile associated to the horizontal alignment. If you need to use a 
different profile other than the active profile, set the Use Active Profile to False 
and select the desired profile next to the Profile Name field.

Also, observe in View 1, the purple dashed shape drawn along the corridor. 
This shape represents the Template Drop along the corridor. The Template 
Drop is a closed shape (usually defined by station limits) along the corridor to 
which a specific template is applied at a defined interval.
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2. Review Template Drop Properties.

a. To access the Template Drop Properties, select the Template Drop Handle or any part of the template drop shape.

b. Hover your cursor over the boundary for a few seconds. A context sensitive toolbar will appear, giving you access to other template 
tools.

c. Select the Template Properties icon on the toolbar to review the properties of the template drop.

If you need to make changes to the template drop, the adjustments can simply be made in the dialog.
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In addition to the Corridor Object and Template Drop displayed in 2D you will see additional linear features (edge of pavement, edge of 
shoulder, ditch lines, etc.) that were created as part of the corridor creation process. These linear features are created automatically in 2D and 
3D views.

The 3D model can be displayed as components, linear features, a top surface mesh, or a bottom surface mesh. This is defined by the 
Corridor Feature Design assigned to the corridor when it is created. In our case the Corridor Feature Definition used was Conceptual.

In addition some 2D geometry elements may also be displayed as part of the corridor depending on how the Feature Definitions are setup 
in your workspace. All of the Corridor Feature Definitions delivered with the OpenRoads Designer are set up to display 3D linear features 
and components and also 2D linear features (template geometry) in the 2D model.
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2D linear features are created when:

 The Feature Definition’s Create Template Geometry parameter is set to True, AND 

 When the Corridor Feature Definition Create Linear Feature setting is ON.

For now, it is important to know that the 2D view may be showing 2D features collinear with 3D features referenced from the 3D model. 
This is very powerful but can be distracting at times. 

But remember, you always have control over what you see in the 2D view. You control that view by turning reference displays on and off 
and by controlling how the 3D model appears which is controlled by the Feature Definition assigned to the Corridor.

3. Review the 3D Model and change the corridor feature definition to Final to increase the accuracy of the Corridor Model.

a. In the 2D view, Select the Corridor.

b. Hover your cursor over the corridor handle for a few seconds. A context sensitive toolbar will appear, giving you access to other 
corridor tools.

c. Select the Corridor Properties icon on the toolbar.

d. Change the Feature Definition from Conceptual to Final. Using Final will offer more accuracy for doing final design modeling (See 
Appendix A for more information on Corridor Feature Definitions).
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Add the Urban Template Drop to the Corridor

1. From the ribbon menu, select Corridors > New Template Drop

2. Select the Corridor in the 2D view.

3. Press the <ALT><Down Arrow> to open the Template Library: LondonRd-Imperial.itl [LondonRd-Metric.itl]

4. Browse to Project Templates and select 2 Lanes + Turn Lane - Urban

5. Left-click OK to accept the template.

6. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Start Station: Snap to the Start Urban Template Drop line in the 2D view

 End Station: 91+00 [2+774]

 Drop Interval: 10 [3]
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Review the Corridor and Add Corridor References

Review the roadway layout and Corridor. Notice we have some intersection areas that need to be addressed. We need to remove the 
shoulder, curb, grading and sidewalk in these intersection areas. The template that is used in the corridor has logic built into it to turn 
off the shoulder, curb, sidewalk and end condition grading components of the template when a specific element feature definition is 
encountered. For this to work however we need to add those elements (with the feature definition) to the corridor as a reference 
element. Adding a Corridor Reference provides the ability to add graphical elements to the corridor processing. By adding graphical 
elements as Corridor References you can target the elements using various corridor modeling tools.

1. Zoom In near the intersection of London Rd. and Church Rd. Notice the white dashed line drawn on the left side of London Rd. 
This line is the intersection match line (or seam line). Since we don’t need shoulders, curb, grading and sidewalks through the 
intersection we will assign this line as a corridor reference which will allow us to automatically turn off the grading and sidewalk 
whenever the intersection match line is encountered. The template that is used in this area was designed to target the intersection 
match line Feature Definition. In addition, Component Display Rules in the template are set such that when the intersection match 
line is added as a corridor reference the shoulders, curb, grading and sidewalk components will turn off automatically on the left or 
right side.

2. Add the intersection match line element as a corridor reference.

a. From the Ribbon menu, select Corridors > Miscellaneous > Corridor References > Add Corridor Reference

b. Locate and Select the London Rd. Corridor.

c. Select the Church_Matchline element (white dashed line that represents the intersection match line for Church Rd.) 

d. Right-click to accept and reset.
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3. Review the 3D Model and notice how the shoulder and grading has now been removed from the corridor.
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Before we continue, lets review the template to get a better understanding of how the template works when a corridor reference element is 
added to the corridor.

4. Select the Create Template tool and open the template library: LondonRd-Imperial.itl [LondonRd-Metric.itl] 

5. Browse to Project Templates and Select 2 Lanes + Turn Lane - Urban

Notice there’s 2 null points located above the centerline of the template. One is named INT_ToRT and the other is named INT_ToLeft. 
These points are set up to seek an intersection match line if it’s added as a corridor reference element to the corridor.

6. Double Left-click on the point named INT_ToRT and review it’s point properties. Observe in the bottom portion of the dialog the 
Horizontal Feature Constraint is set to search or seek a feature definition named Matchline. If an element is defined with the 
Matchline feature definition and is then added as a corridor reference element then the INT_ToRT point will move horizontally to 
that location. Once the point moves it triggers a Component Display Rule that turns off the curb & gutter, sidewalk and grading 
components automatically.

7. Close the Point Properties dialog.

8. Double Left-click on the right curb and gutter component and review the component properties. Notice there is a Display Rule defined. 
That display rule is what displays and undisplays the curb & gutter, sidewalk and grading components.
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9. Close the Component Properties dialog.

Test the INT_ToRT point to understand how the template behaves when the point is moved horizontally.

10. Select the INT_ToRT 

11. Right-click and select Test Point Controls > Test Horizontal Point Control

12. Move the point to the right and observe that the curb & gutter, sidewalk and grading components turn OFF as the point is moved to the 
right.
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Add Corridor References for the Ramp C and Ramp D intersection. Intersection match 
line elements have been created for all intersections along the corridor.

13. Zoom In near the Ramp C and Ramp D intersection.

Add the intersection match line elements as a corridor references.

14. From the Ribbon menu, select Corridors > Miscellaneous > Corridor References > 
Add Corridor Reference

Following the heads up prompts (after each prompt, Left-click to accept values and 
move to next prompt):

 Locate Corridor: Select the London Rd. Corridor.

 Locate First Reference Element: Select the left white dashed line that represents 
the left intersection match line for Ramp C.

 Locate Next Reference: Select the right white dashed line that represents the 
right intersection match line for Ramp D.

15. Right-click to accept and reset.

16. Review the 3D Model to make sure the components have been undisplayed in the 
intersection area.

17. Continue adding corridor references for the remaining intersections (Ramp B-Ramp 
A and Forest Ct.) using the steps described above. Intersection match line elements 
have been created for all intersections along the corridor. Do not add corridor 
references for the 2 driveways. We will use a different approach to handle the 
driveways.
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18. Review the Corridor 3D model to ensure the intersections areas are correct.
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Review the Corridor Reference Elements Using the Corridor Objects tool

The Corridor Objects tool allows you to review and modify the corridor. We will now use the Corridor Objects tool to review the Corridor 
Reference Elements that we added to the Corridor.

1. Select the Corridors > Edit > Corridor Objects tool. 

2. Select the London Rd. Corridor.

3. From the Corridor Objects dialog, select External Reference

The External Reference portion of Corridor Objects shows you all the geometric elements that have been assigned as corridor reference. 
In our case, all of the intersection matchline elements that we added as corridor references. When you select a reference element in the 
list it will highlight in the 2D view. 

You also have the ability to add or delete corridor references using the Add and Delete buttons at the upper left portion of the dialog. By 
selecting an individual Corridor Object such as a Template Drop, Secondary Alignment, Key Station, Point Control, End Condition 
Exception, External Reference or Clipping Reference, the object will highlight in the 2D View.

4. Close the Corridor Objects dialog.
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Exercise 2: Add Template Drops at Driveways

Description
In this exercise, you will learn how to add template drops between the two driveways and also how to transition the curb height across 
the driveways. We will use 2 different methods to place the templates drops. The first method will be to create a new template drop and 
then edit the template drop and the second method will be making a copy of a template drop. We will not cover the detailed modeling 
of the driveway at this time. That will be covered in a separate course.

Skills Taught
 Create New Template Drops

 Edit Template Drops

 Copy Template

 Copy Template from Corridor to Template Library with Template Library Organizer

 Activate and De-Activate Corridor Processing

 Create Parametric Constraints to transition the curb height

 Import Parametric Constraints
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Add Template Drops at Driveway 1

Now that we have modified the corridor in the intersection areas we need to address the 2 driveways on the right side of our corridor. 
Right now, the curb, sidewalk and grading is going through the driveways. In this section you will add additional template drops at the 
drives and edit the template drops to remove components that we don’t need.

1. From the Ribbon menu select Corridors > New Template Drop

2. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

a. Locate Corridor: Select London Rd. Corridor

b. Select Template: Press ALT and the Down Arrow on your keyboard. The Pick Template window will appear.

c. Expand the folders to Project Templates 

d. Select the 2 Lanes + Turn Lane-Urban template.

e. Click OK and Left click to accept.

Continue following the heads up prompts (after each prompt, Left-click to 
accept values and move to next prompt):

f. Start Station: Snap to the Start Template Drop Driveway 1 line in the 2D 
view

g. End Station: Snap to the End Template Drop Driveway 1 line in the 2D view

h. Drop Interval: 10 [3]

Tip: Recall, that when you snap to a line (or any element) in a design file to 
establish the start/end station of your template drop, the software will 
remember that you snapped to that line because of the rules and relationships 
and design intent that is built into the software. If you move the line the 
template drop start/end station will update automatically.
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The template drop for Driveway 1 is now created. 

Review the Template Drop and Edit the Template Drop.

3. Select the Template Drop (purple dashed line) you just created and review the start and end stations. 

Recall, the start and end stations can be modified by selecting the station text and keying in a new value as needed or by grabbing 
the drag handle arrows. Also, note the key-point snap icon attached to the template drop as shown in the image above. The snap 
icon indicates that the template drop was created by snapping to a graphic element and a relationship and rule exists there.

If you delete the graphic element the snap rule will be removed and if you move the graphic element the template drop will move. 
Furthermore, if you edit the station text or edit the template stations via the drag handles the relationship between the snapped 
graphic line will be lost. It’s important to remember this concept when snapping to graphic elements.
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4. Hover your cursor over the template drop until the context sensitive menu appears.

5. Select Edit Template Drop

Edit Template Drop will allow you to make edits to the template drop directly in the corridor. When template drops are created, 
templates are copied from the template library and become part of the corridor object. Thus, any edits made in the corridor ARE 
NOT automatically stored in the template library but in the corridor itself and only between the station range of the template drop.

6. Locate Template Drop: Select the Driveway 1 template drop
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7. Edit the Template Drop

a. Right-click in the Edit Template view window.

b. Select Delete Components.

c. On the right side of the template, delete the front and back sidewalk berm components, sidewalk component and all end 
condition components. Left-click in the template window and while holding down the left mouse button, drag your cursor over 
the components to be deleted. 

Edited template should look like the image below.

d. Click OK to complete
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Create a New Template Drop for Driveway 2

Editing the Template Drop is one way to handle the driveway. For Driveway 2 we will use the Copy Template tool to copy the previous 
template drop since Driveway 2 is essentially the same.

1. From the Ribbon menu select Corridors > Copy Template Drop

2. Continue following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt)

a. Locate Template Drop: Select Driveway 1 Template Drop 

b. Start Station: Snap to the Start Template Drop Driveway 2 line

c. End Station: Snap to the End Template Drop Driveway 2 line

The template drop from Driveway 1 will be copied and used for Driveway 2.
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Copy the Edited Template from the Corridor to the Template Library

When a template is edited directly in the corridor using the Edit Template tool, the edited template is stored directly in the corridor and 
not the template library (.itl). If you need to store the edited template into the template library you can accomplish this by using the 
Template Library Organizer. The Template Library Organizer will allow you to copy templates from corridors and other template 
libraries and store them in the active template library. The following steps will show you how to copy the edited template from the 
corridor and save it to the template library.

1. Open the Create Template tool.

2. Go to Tools > Template Library Organizer

3. Expand the Active Design File Corridors list on the right to 
the London Rd. folder. Note the edited template has the 
date and time appended to the original template name.

4. Expand the Template Library on the left to the Edited From 
Corridor folder.

5. Drag and Drop the edited template into the Template 
Library folder called Edited from Corridor

6. Click OK

The edited template is now part of the active template 
library. Now you can rename it, modify it or copy it to the 
Project Template folder to be used later when you 
encounter other driveways.

7. Go to File > Save to save the template library.

8. Close the Create Template window.
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Create Parametric Constraints to Create Dropped Curb and Transition Curb Height at Driveways

In this section, we will use parametric constraints to override the default curb height so that we can place a dropped curb and also 
transition between dropped curb and full height curb. Recall, Parametric Constraints allow you to override template point constraint 
values. The Create Parametric Constraints tool gives users the ability to vary pavement thickness, curb height, ditch widths, slopes, 
etc. between any station range along a corridor. 

Review the 3D Model where the two driveways are located. Observe that the curb height across each driveway needs to be adjusted. 
We need to create a dropped curb across each driveway and also transition the curb from full height to dropped curb and then from 
dropped curb back to full height curb. We will use Parametric Constraints to accomplish this.
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1. Modify the curb height to 0.083’ [0.03 m] across the driveway.

a. From the ribbon menu select, Corridors > Edits > Create Parametric Constraint

The following dialog box will appear.

Notice the field called Constraint Label, this is where you pick the parametric 
constraints you want to modify or adjust. The constraint labels are created and 
assigned to template point constraint values in the template that is currently 
assigned to the corridor (see Template Point Properties image). 

Each Constraint Label has a default value and by utilizing the Create Parametric 
Constraint tool you can easily modify or override the default values over a station 
range without having to create a new template or make modifications to the 
template. 

b. Follow the heads up prompts (after each prompt, Left-click to accept values and 
move to next prompt):

 Locate Corridor: Select London Rd. Corridor

 Start Station: Select Start Drop Curb Driveway 1 line

 End Station: Select End Drop Curb Driveway 1 line

 Constraint Label: Curb Type 1 Curb Height_R

 Start Value: 0.083 [0.03]

 End Value: 0.083 [0.03]

2. Create the same curb height adjustment for Driveway 2 using step 1 as a guide. Snap to the start and end drop curb graphic lines to 
determine the start station and end station for the curb height transitions.
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3. Review the 3D model.
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Template Library Changes and Synchronize with Template Library

In the previous exercises we made changes to the template by using Edit Template Drop and Create Parametric Constraints. We didn’t make 
any changes to the templates in the actual template library (.itl). Sometimes a template needs to be changed in the template library and re-
applied to the corridor. The tool used to re-apply a template to a corridor is called Synchronize with Library.

By default, when you create a template drop, the chosen template is copied from the template library (.itl) into the corridor. If you modify the 
template in the template library after you’ve created the corridor and template drop it will be necessary for you to synchronize your template 
library so that any modifications you made to the template can be applied to the corridor.

Synchronize with Template Library Process: 
1. In the 2D view, select the template drop you wish to synchronize.

2. Hover your cursor over the template drop element until the context menu appears.

3. Select the Synchronize with Library icon and the corridor will re-process using the template from the template library.

Also, note that any template that has been changed in the template library (and not synchronized) in the corridor will appear red in the 
Corridor Objects dialog. After synchronizing the template drop the color will change back to black. 

Important Note: If a template has been modified in the corridor the template drop will also appear red. Always be aware of how you 
edited a template drop.
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Create Key Stations at Driveway 1 and Driveway 2 Centerline

Before we continue, we are going to create Key Stations at the driveway centerlines. Key Stations give you the ability to add template 
drops at user specified locations along the corridor. They are used to add stations that are not coincident with the template interval, 
when a special circumstance of the project occurs and it's desirable to include the station in corridor processing. Adding Key Stations 
at the driveway centerline locations will ensure that a template drop will occur at each driveway.

1. Select Corridors > Edits > Create Key Station

Follow the heads up prompts (after each prompt, Left-click to accept values and 
move to next prompt):

a. Locate Corridor: Select the London Rd. Corridor

b. Station: Snap to the end point of the Driveway 1 centerline.

2. Create Key Station for Driveway 2

Follow the heads up prompts (after each prompt, Left-click to accept values and 
move to next prompt):

a. Locate Corridor: Select the London Rd. Corridor

b. Station: Snap to the end point of the Driveway 2 centerline

Once the Key Stations are places a red dashed line will display in the 2D model. 
This is the graphical manipulator for the key stations. Selecting it gives you the 
ability to adjust the key station via the drag handle arrows or editing the dynamic 
text.
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Exercise 3: Create Turn Lane Template Drops

Description
Now that we’ve learned how to handle intersections and driveways along the corridor, let’s focus our attention on areas where we have right 
turn lanes that need to be added to the corridor. In this exercise we will create additional template drops in areas where right turn lanes are 
needed. We will then add corridor references and point controls to force the corridor to follow edge of pavement geometry where the template 
needs to widen for turn lanes.

Skills Taught
 Create Template Drops

 Add Corridor References to follow edge of pavement geometry

 Create Point Control to follow edge of pavement geometry

 Create Secondary Alignment



Copyright © 2021 Bentley Systems, Incorporated 38DO NOT DISTRIBUTE - Printing for student use is permitted

Create Template Drops for Right Turn Lanes

In this section we are going to create template drops in the right turn lane areas and then assign corridor references and point controls.
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1. Open the Create Template tool.

2. Select Project Templates > 2 Lanes + Turn Lane + Aux Lane-LT-Urban template

3. Review the template. 

Notice there is a point named CP_EOP_L, this point will be used to control how the template widens horizontal to add the right turn lane.

4. Double Left-click on CP_EOP_L and review the point properties and take note that this point is set up to seek an EdgeOfPavement 
feature definition. Recall, if we add a geometric element as a corridor reference and that element has this feature definition the template 
point will move horizontally to that location automatically. 

5. Close the Point Properties dialog.
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Test the CP_EOP_L point to understand how the template behaves when the point is moved horizontally.

6. Select the CP_EOP_L point 

7. Right-click and select Test Point Controls > Test Horizontal Point Control

8. Move the point to the left and observe that a right turn lane, curb & gutter, sidewalk and grading components turn on as the point is 
moved to the left. This happens because there is a Component Display Rule set up to turn on the components we need when the 
CP_EOP_L point is moved to the left. By default those components are turned off. They will only appear if you add a corridor reference or 
point control to the CP_EOP_L point.

9. Close the Create Template window.

10. Create Right Turn Lane Template Drop on the left side of the corridor. Apply the following settings and image below as a guide:

a. Template Name: 2 Lanes + Turn Lane + AuxLane-LT-Urban

b. Start Station: Snap to the begin turn lane line

c. End Station: Snap to the end turn lane line

d. Interval: 10 [3]
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11. Create Right Turn Lane Template Drop on the right side of the corridor. Use the following settings and image below as a guide:

a. Template Name: 2 Lanes + Turn Lane + AuxLane-RT-Urban

b. Start Station: Snap to the begin turn lane line

c. End Station: 91+00.00 [2+774]

d. Interval: 10 [3]

12. Review the 3D Model in the turn lane areas and note that the turn lane is not displayed. This is by design, in order for the turn lane to 
display you must add the edge of pavement as a corridor reference or create a point control to follow the edge of pavement.
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Add the Left Edge of Pavement as a Corridor Reference

1. From the Ribbon menu select Corridors > Miscellaneous > Corridor References > Add Corridor Reference

Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Corridor: Select the London Rd. Corridor.

 Locate First Reference Element: Select the left edge of pavement geometry that defines the turn lane.

 Locate Next Reference: Select the left edge of pavement taper geometry.

2. Right-click to accept and reset.

3. Review the 3D Model to make sure the turn lane, curb & gutter, sidewalk and gutter components are now displayed. Also, notice the left 
edge of pavement taper area and note that the direction of template processing is perpendicular to the corridor baseline. By default, 
template drops and template processing are defined perpendicular to the baseline. We want to change that and force the template 
processing to change direction and be perpendicular to the left edge of pavement taper. We will accomplish this by assigning the left edge 
of pavement taper to be a Secondary Alignment. When you assign an element to process as a Secondary Alignment it changes the 
template processing direction to be perpendicular to the Secondary Alignment.
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4. Add a Secondary Alignment to change the direction of the template processing to go perpendicular from the left edge of pavement taper.

a. Select Corridors > Edits > Create Secondary Alignment

b. Follow the heads up prompts (after each prompt, Left-click to accept 
values and move to next prompt):

 Locate Corridor: Select London Rd. Corridor

 Locate Secondary Alignment: Select Edge of Pavement Taper 
on the left side of the corridor.

 Start Station: Snap to begin point of taper

 End Station: Snap to end point of taper

 Start Offset: 0.0

 End Offset: 0.0

5. Review the 3D Model where you created the Secondary Alignment.
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6. Rotate the 3D View to Top and note how the template drop changed direction and is now perpendicular the edge of pavement taper we 
defined as a Secondary Alignment.

Tip: When secondary alignments are created, a graphical manipulator is drawn in the 2D view which enables you to graphically edit the 
secondary alignment.
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Create Point Control for Right Edge of Pavement Taper

Now that we’ve taken care of the turn lane on the left side of the corridor. You will now address the turn lane on the right side of the corridor. In 
the previous section, we added the left edge of pavement geometry as a corridor reference to add the right turn lane. In this section we’ll take 
a slightly different approach using a Point Control to add the turn lane on the right side of the corridor. Recall, Point Controls can be assigned 
to corridors to force the template points to follow other information than what is set in the template. Point controls override the default location 
of template points.

1. Create a Horizontal Point Control to follow edge of pavement geometry on the right side of the corridor.

a. Select Corridors > Edits > Create Point Control

b. Follow the heads up prompts (after each prompt, Left-click to accept values and 
move to next prompt):

 Corridor: Select the corridor

 Start Station: Snap to Start Template Drop Right Turn Lane line

 End Station: 91+00 [2+774]

 Control Description: Right EOP Control

 Locate Point: EOP_R

 Mode: Horizontal

 Control Type: Linear Geometry

 Locate Plan or Profile Element: Select the right edge of pavement geometry 
in the turn lane area

 Use as Secondary Alignment: Yes

 Priority: 1

 Start Offset: 0

 Stop Offset: 0
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2. Review the 3D Model to ensure the Corridor displays the turn lane, curb & gutter, sidewalk and grading.

Tip: When point controls are created, a point control graphical manipulator is drawn in the 2D view which enables you to graphically edit the 
point control if needed.
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Assign Superelevation to the Corridor

Now that all of the template drops have been created let’s go ahead and assign superelevation to the corridor. In order 
to assign superelevation to a corridor the superelevation needs to be created in the corridor design file or created in a 
separate design file and attached as a reference file. Superelevation data has been previously created in the 
Superelevation-LondonRd.dgn that is attached as a reference.

1. Turn On the Superelevation-LondonRd.dgn reference file to view the superelevation data.

a. Left click in View 1 to make it the active view.

b. Select Home > Primary > Attach Tools > References

c. Select the Superelevation-LondonRd.dgn [Metric-Superelevation-LondonRd] 

d. Click the Display Reference icon at the bottom of the window to turn On the file.

e. Close the References window.
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2. From the ribbon menu select Corridors > Superelevation > Calculate > Assign to Corridor

a. Select superelevation section shape and Right-click to accept it.

b. Select the Corridor.

c. Review the Associate Superelevation window and click OK

This dialog shows the two template points that define each superelevation lane and which of those points the lane pivots about. The 
points that will be used for superelevation are defined in the template when the Superelevation Flag is enabled on the template point. 
The Superelevation Flag identifies the template points that will be used as the Pivot Point and Superelevation Point. In this case, the 
template points: CL , LL_A_L, LL_A_R have Superelevation Flags enabled. Also, note that the Superelevation Flag has not been 
enabled for the EOP_L and EOP_R. This is by design since we are using a vector offset constraint on those points to match the slope 
created between the CL and LL_A_L points and the slope between CL and LL_A_R points.
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Review the Cross Sections

1. From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross Section View tool.

2. Locate and select the Corridor.

3. Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 window will appear.

4. Click in View 7, a cross section should now appear.

Note: This view window is showing dynamic cross sections extracted from the 3D model. All elements in the 3D model will appear in the 
cross section.

Also, note the magenta boxes that appear on the cross sections. These boxes indicate a superelevation point control has been created 
and assigned to the corridor. When any point control is created the point being controlled is displayed on the cross section with a magenta 
box.
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5. Using the cross section navigation tool at the top of the cross section view window. Navigate through the cross sections to review the 
cross sections.

TIP: Right of way markers show up on the cross section automatically. This happens because the right of way file is attached as a 
reference and the right of way feature definition is configured to display a right of way marker on the cross sections.

6. Turn off Superelevation-LondonRd reference file.

a. Select Home > Primary > Attach Tools > References

b. Select the Superelevation-LondonRd.dgn [Metric-Superelevation-LondonRd] 

c. Click the Display Reference icon at the bottom of the window to turn OFF the file.

d. Close the References window.
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Create Parametric Constraints for Center Turn Lane Width, Shoulder Slope & Ditch Width

Now that we have created all of the template drops for the corridor, we need to manipulate the corridor a little more based on some 
design changes we received from the design team. In the beginning of the corridor we need to transition the pavement lanes from a 2 
lane pavement section to 2 lanes + Center Turn Lane section. We’ll accomplish this again by using Parametric Constraints to transition 
into a 12’ [3.7 m] center turn lane with two 12’ [3.7 m] travels lanes. We’ll also adjust the shoulder slope to transition from the existing 
slope to -4.00% and then we’ll adjust the ditch width to change from 2’ [0.61 m] to 0’ [0 m] to form a v-ditch.

1. Create the Parametric Constraints for Center Turn Lane Width (Lane A Width_L = -6.0 [-1.8] and Lane A Width_R = 6.0 [-1.8])

a. Select Corridor Objects

b. Select the London Rd Corridor

c. Select Parametric Constraints from the corridor object list on the left.

d. Select the Deactivate Rule Icon to deactivate the corridor processing (the icon will change to an UNLOCKED icon). 

Deactivating the corridor processing will prevent the corridor from updating and processing every time we create new parametric 
constraints. Unlocking the corridor can save time when a lot of edits need to be made.

e. Select Add New Parametric Constraints

f. Follow the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Start Station: 50+00.00 [1+524]

 End Station: 52+00.00 [1+585]

 Constraint Label: Lane A Width_L

 Start Value: -0.01 [0]

 End Value: -6.0 [-1.8]
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g. Follow the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Start Station: 50+00.00 [1+524]

 End Station: 52+00.00 [1+585]

 Constraint Label: Lane A Width_R

 Start Value: 0.01 [0]

 End Value: 6.0 [1.8]

2. Create Parametric Constraints for Shoulder Slopes and Ditch Width using the previous steps and table below as a guide:

3. After creating all Parametric Constraints re-process the corridor to apply the updates.

a. Select the Unlock - Activate Rule icon to activate and re-process the corridor so the new values are applied to the Corridor.

b. Close the Corridor Objects dialog.

Tip: If the corridor does not update, use the Process Corridor tool to update the corridor.

Shld Slope_L Shld Slope_R Ditch Bottom Width_L Ditch Bottom Width_R

Start Value 0.60% -0.60% 0 0

Stop Value 4.0% -4.0% 0 0

Start Station 50+00 [1+524] 50+00 [1+524] 50+00 [1+524] 50+00 [1+524]

Stop Station 52+00 [1+585] 52+00 [1+585] 52+00 [1+585] 52+00 [1+585]
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Review the 3D Model and Cross Sections to make sure the parametric constraints are working as designed.

4. Navigate through the cross sections by pressing the single right arrow to move to the next cross section. Note the green boxes that 
appear on the cross sections. The green boxes indicate the locations on the template where Parametric Constraints have been assigned.

5. Review the cross section to make sure the parametric constraints for the turn lane widths, shoulder slopes and ditch widths have been 
applied along the corridor. If the green boxes are not shown, the parametric constraints have not been applied.
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Import Parametric Constraints

Design scenario: You just received a new pavement design from the design team. The new pavement design calls for the first 
pavement layer depth to be 1-1/4” (31.75 mm) and the second pavement layer depth to be 1-3/4” (44.45 mm). We are going to change 
the current pavement depths to the new pavement depths by importing the values from an ASCII text file. Importing Parametric 
Constraints via text file can sometimes be more efficient then manual creation.

1. Since we have parametric constraints labels for all pavement layers set up in the project templates we are going to do a global update 
in the corridor very quickly by importing the new pavement depth values from an external ASCII text file. The new pavement depth 
values will be assigned to the Pavt 1 Depth & Pavt 2 Depth parametric labels by importing the values from an ASCII text file.

a. Open the PavementDesign.txt [Metric-PavementDesign.txt] with any Notepad, Wordpad or any text editor.

b. Review the format of the file.

c. Close the PavementDesign.txt [Metric-PavementDesign.txt] 

2. Import the Parametric Constraints from the PavementDesign.txt [Metric-PavementDesign.txt] file.

a. Select the Corridor Objects tool

b. Select the London Rd Corridor

c. Select Parametric Constraints from the left side of the dialog.

d. Select the Deactivate Rule Icon to deactivate the corridor processing (the icon will change to an UNLOCKED icon). 

Deactivating the corridor processing will prevent the corridor from updating and processing as we import the new parametric 
constraints from the PavementDesign.txt [Metric-PavementDesign.txt] 

e. Select the Import Parametric Constraint tool

f. Select the PavementDesign.txt [Metric-PavementDesign.txt] file

g. Select Open. The Parametric Constraints for Pavt 1 Depth and Pavt 2 Depth will be added to the Corridor.

h. Select the Unlock - Activate Rule icon to activate and re-process the corridor so the new values are applied to the Corridor.

i. Close the Corridor Objects dialog. Tip: If the corridor does not update, use the Process Corridor tool to update the corridor.
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Review the cross sections to ensure the pavement layers have been adjusted.

3. Navigate through the cross sections by pressing the single right arrow to move to the next cross section. Review the cross sections to 
make sure the parametric constraints for the pavement depths have been applied along the corridor. If the green boxes are not shown, 
the parametric constraints have not been applied.
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Exercise 4 - Corridor Clipping, Target Aliasing and End Condition Exceptions

Description
So far, you have only been working on one specific corridor. What happens if you need to interact with other corridors within a project? 
In this exercise we’ll take a look at how to use Corridor Clipping to clip out a portion of the S.R. 97 corridor where it crosses over the 
London Rd. corridor and how we can use target aliasing to target other corridors and terrains. We will then show how to override the 
default end conditions using End Condition Exceptions.

Skills Taught
 Corridor Clipping

 Target Aliasing

 End Condition Exceptions
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Corridor Clipping

In this section, we are going to clip out (or remove) part of the S.R. 97 corridor where it crosses over the London Rd. corridor. We are 
doing this because there will be a bridge constructed over London Rd. and it is modeled in a separate corridor. In addition, there are 
also bridge abutment walls constructed adjacent to London Rd.

1. Select Save Settings to save the settings for the Corridor-LondonRd.dgn [Metric-Corridor-LondonRd.dgn].

2. Open Corridor-SR97.dgn [Metric-Corridor-SR97.dgn].

3. Review the 3D model and notice that the SR97 corridor is overlapping London Rd. We are going to use corridor clipping to remove the 
overlap.

4. Review the attached reference files, note we have bridges and abutment walls also attached as corridors. We are going to clip out the 
portion of the SR97 corridor where the bridges cross over London Rd.

In the 2D view there is a shape drawn in the area where the bridge crosses over London Rd. We will use this shape as a corridor clipping 
reference to clip the SR97 corridor and remove the overlap with London Rd.

5. Select Corridors > Corridor Clipping > Add Clipping Reference

Follow the heads up prompts (after each prompt, Left-click to 
accept values and move to next prompt):

a. Select Corridor to Be Clipped: Select the SR97 corridor.

b. Locate First Clipping Reference: Select the bridge clipping 
shape.

c. Reset to complete.
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6. Review the 3D Model and notice the Bridges and Abutment Walls are now more visible.

Tip 1: The bridges can be modeled in detail using Bentley OpenBridge Modeler. Or you can create a fairly accurate model of the bridge by 
creating a corridor and using a bridge template. 

Tip 2: The abutment walls can be created as a corridor or by utilizing linear templates. Methods to create walls are covered in other 
courses.

7. Open Corridor-LondonRd.dgn [Metric-Corridor-LondonRd.dgn]

8. Left-click in the 3D view to make it active.

9. Select Home > Attach Tools > References

10. Select and turn ON the display for the following references: Corridor-SR97, Corridor-Bridges and Corridor-AbutmentWalls

11. Close the References window.

12. Review the 3D model and cross sections where S.R. 97 cross over London Rd. Now that the 3D models for S.R. 97, S.R. 97 Bridges and 
Walls are displayed in 3D, they will automatically appear on the dynamic sections.
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Target Aliasing and End Condition Exceptions

In this section you will learn how to target other corridors and terrain and how to override the default template end conditions. We’ll first 
learn how to target the abutment walls using target aliasing and then we will take a look at how to override the default end conditions 
using End Condition Exceptions.

By default, all end condition solutions are targeting the existing terrain model which is the active surface or active terrain. We want to 
change that so that the end conditions target other items along the corridor such as the abutment walls as well as the existing terrain 
model. We will accomplish this by using a tool called Define Target Aliasing. Target Aliasing allows you to target other corridors, 
terrains or features and to set up a prioritized target list for end condition solutions on terrains, corridors or features.

1. Define Target Aliasing

a. Select Corridors > Define Target Aliasing

b. Select London Rd. Corridor, after selecting the corridor the Define Target Aliasing dialog will appear.

The left portion of the dialog displays a list of available terrains, corridors or features that you can target. The right portion of the dialog is 
where you define the Aliases (target terrains, corridors or features) and the processing order. When an end condition seeks a target it will 
start at the top of the Aliases list. If a target is not found the end condition will then work its way down the list until a target is found.
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c. Follow the heads up prompt and Locate Alias Entries to add to the Aliases list:

 In the 2D view, Select the RearAbutWall Corridor

 In the 2D view, Select the AheadAbutWall Corridor

 In the 2D view, Select the Existing_Terrain

Note: You can also pick these items from the list and use the Add-> button to 
add them to the Aliases list.

The selected corridors and terrain are now added to the Aliases list.

d. Make sure Use Closest IS NOT checked.

e. Click Apply. The corridor will process and update based on the new target 
aliases you defined. In the areas where the abutment walls exist, the end conditions will solve to the walls, in the areas where the walls 
are not found the solution will just default to the existing terrain model.

2. Review the 3D model and Dynamic Sections to ensure the end conditions are now targeting the walls.
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In the areas where the walls exist the end conditions tie to the walls, although there are some small areas where the end condition just 
ties to ground. This happens because the current end conditions in the template cannot find a solution to solve to the walls for all cases. 
The corridor will look at the first end condition priority for a solution, if a solution is not found it will then try to process all the aliases before 
moving to the next end condition priority. Thus, it is possible that a target is never found from the alias list and the end condition will just 
solve to the active surface.
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3. Create End Condition Exceptions to place a 8:1 ditch backslope on the left and right side of the corridor in the area of the walls. End 
Condition Exceptions are used to override the default template end conditions between a user defined station range.

a. Select Corridors > Edits > Create End Condition Exceptions

b. Follow the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate and Select the London Rd. Corridor

 EcException Name: LT Wall Grading

 Apply ECE To: Left Override

 Start: 69+51 [2+119]

 Stop: 72+51 [2+210]

After entering and accepting the end condition exception information the Template Editor window will appear. 
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When creating end condition exceptions you must modify or delete the original end condition in order for the new end condition 
exception to be applied to the corridor. 

Also, only end condition components can be deleted or modified. In our case we are going to delete the default end condition and 
replace it with a brand new end condition.

Delete all end condition components on the left side of the template.

c. Right-click in the template window and Select Delete Components
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d. Left-click in the template window and while holding down the left mouse button, drag your cursor over the all end condition 
components to delete them. Once they are deleted they will turn light blue.

e. Expand the Template Library folders to Project Templates
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f. Select EC-Wall Grading LT and drag and drop it onto the end point of the back of sidewalk berm.

g. Click OK to complete the end condition exception. The corridor will re-process and update with the new end condition.
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When an End Condition Exception is created a light blue graphical manipulator will be 
drawn in the 2D model that will enable you to easily locate and also edit the end condition 
exception if needed.

4. Select the end condition exception in the 2D model.

5. Hover your cursor over the end condition exception until the context menu appears.

Note there are 3 tools available to review and edit the End Condition Exception: 

Properties 

Edit End Condition Exception 

Delete End Condition Exception

6. Left-click anywhere in the 2D model to de-select the end condition exception.

7. Create an end condition exception for the wall grading on the right side of the corridor.

Use the procedures described in step 3 as a guide.

 EcException Name: RT Wall Grading

 Apply ECE To: Right Override

 Start: 70+13 [2+138]

 Stop: 73+13 [2+229]

 End Condition Template: EC-Wall Grading RT
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(Optional Exercise) Create End Condition Exception for Left Ditch

In this section, we will create another end condition exception for a ditch on the left side of the corridor. There is a cut ditch that forms 
over a small distance on the left side of the corridor between 66+00 and 66+40. Create an end condition exception to eliminate the 
ditch and force a 6:1 fill slope

1. Create End Condition Exceptions to override the cut ditch end condition on the left side of the corridor between 66+00 [2+013] and 66+40 
[2+022].

a. Select Corridors > Edits > Create End Condition Exceptions

b. Follow the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate and Select the London Rd. Corridor

 EcException Name: LT Fill

 Apply ECE To: Left Override

 Start: 66+00 [2+013]

 Stop: 66+40 [2+022]

c. Delete the cut ditch end condition.

d. Drag and drop the EC-Fill 6:1 end condition onto the template left hinge point.

e. Review the 3D model and cross sections to ensure the end condition exception was created with a 6:1 fill slope.
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Review the Corridor Model with OpenRoads Model Explorer

Now that the corridor model is complete you may want to go back and review all of the changes you made to the corridor. In this 
section, you will learn how to review the Corridor Model and all the data associated to the corridor with the OpenRoads Model 
Explorer. All OpenRoads Designer data is organized and displayed in the OpenRoads Model Explorer. The Explorer tool can be used 
to browse and manage data in the design file. You can also use it to search, zoom to and isolate data. As the design progresses, the 
information is continually created/updated automatically.

1. Review the corridor objects that are part of the corridor with OpenRoads Model Explorer

a. From the ribbon menu, select Explorer

Expand the OpenRoads Model group by pressing the down arrow.

TIP: It is wise to always have Explorer open when working in OpenRoads Designer.
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b. Select Corridors from the list

c. Click the small arrow next to Corridors to expand the list to see next item in the 
list.

d. Continue expanding the list until you see all of the corridor objects in the list 
(Templates, Point Controls, Key Stations, Secondary Alignments, End Condition 
Exceptions, Parametric Constraints and Target Aliases).

e. Expand each corridor object category to see all the items that were added to the 
corridor.

f. Select a Template Drop from the Templates category.

Notice in the 2D view, the template drop highlights. Whenever you select an item 
from the list, it will highlight in the 2D view.

Selecting an item and then doing a right click will give you access to other 
corridor modeling tools.

The OpenRoads Model Explorer manages and keeps track of all civil data stored in the dgn file. It is usually a good idea to keep it 
open at all times so you can easily review your civil data as you progress with your design work.
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Appendix A - Corridor Feature Definitions

Corridor Feature Definitions are preset bundles of settings that control how corridors appear in the 3D model. The also control the level of 
detail included in the 3D model. For preliminary work a Corridor Feature Definition that creates a less detailed 3D model is very useful to 
speed up processing. While later in a project a Corridor Feature Definition for final work is used to produce the most accurate 3D model 
necessary for construction.

Corridor Feature Definitions should be defined in a dgnlib and can be reviewed and edited using OpenRoads Standards tab in the OpenRoads 
Explorer tool. Once a Corridor Feature Definition is used, it is copied to the local file just like other elements such as levels, element templates, 
text styles, and feature definitions.
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Corridor Feature Definitions have four categories of parameters:

Feature Definition

Defines the corridor feature definition name, description and seed name.

Processing & Critical Sections

One of the parameters of a Corridor Feature Definition is the Template Drop Interval Multiplier. The Template Drop Interval is the interval 
specified when the corridor is created that defines the distance between template drops -- the interval at which cross sectional geometry along 
the corridor is modeled. 

The Template Drop Interval Multiplier increases the template drop interval resulting in a less dense model. For example, the Conceptual 
feature definition has a multiplier of 10. So instead of a model being processed every 10’ [3 m], it is modeled every 100’ [30 m] which results 
in faster processing speed.

Another way Corridor Feature Definitions can speed up processing is by omitting Critical Sections such as horizontal curve cardinal points.

Manipulator Settings

The display settings define how the corridor object appears including its color, weight, etc. and the size of the handles that surround it. There 
are also settings for the appearance of the Template Drop and Transition object graphics that appear in the 2D view.

Display Settings

The Display Settings parameters define the type of 3D elements that are created in the 3D model. Options to display/undisplay Top Mesh, 
Bottom Mesh, 3D Linear Features and Components can be found in Display Settings.
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Display Settings Examples
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. Corridors should always be created in a 2D dgn? 

a. True 

b. False

2. What does the Corridor Feature Definition do?

a. Controls the view attributes of the 3D model. 

b. Controls the Symbology of the cross sections.

c. Controls the display and accuracy of the 3D model.

3. Which tool gives users the ability to vary pavement thickness, ditch widths, slopes, etc. between any station range along a corridor.

a. Create Point Control 

b. Create Parametric Constraint

c. Corridor Objects

4. Templates are stored in an external template library (.itl file).

a. True 

b. False

5. Which tool lets you review and modify overrides that have been applied to the corridor?

a. Corridor Objects 

b. Create Point Control

c. Create Parametric Contraint

d. Open Cross Section View
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6. Where is the corridor data stored?

a. In an external file with an .IRD 

b. In an external file with an .ITL

c. In the .dgn file

d. OpenRoads Model Explorer

7. What is target aliasing used for?

a. Allows you to target other corridors, terrains or features and to set up a prioritized target list for end condition solutions on terrains, 
corridors or features. 

b. Search for Template Points

c. To Create Point Controls

8. Multiple template drops be assigned to a corridor.

a. True 

b. False

9. When would you create a Secondary Alignment?

a. When you need to make your template follow edge of pavement geometry. 

b. If you need to change the direction of template processing.

c. When you add edge of pavement geometry as a corridor reference.

10. Edited Template Drops are stored in the corridor by default.

a. True 

b. False
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. Corridors should always be created in a 2D dgn? 

a. True 

b. False

2. What does the Corridor Feature Definition do?

a. Controls the view attributes of the 3D model. 

b. Controls the Symbology of the cross sections.

c. Controls the display and accuracy of the 3D model.

3. Which tool gives users the ability to vary pavement thickness, ditch widths, slopes, etc. between any station range along a corridor.

a. Create Point Control 

b. Create Parametric Constraint

c. Corridor Objects

4. Templates are stored in an external template library (.itl file).

a. True 

b. False

5. Which tool lets you review and modify overrides that have been applied to the corridor?

a. Corridor Objects 

b. Create Point Control

c. Create Parametric Constraint

d. Open Cross Section View
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6. Where is the corridor data stored?

a. In an external file with an .IRD 

b. In an external file with an .ITL

c. In the .dgn file

d. OpenRoads Model Explorer

7. What is target aliasing used for?

a. Allows you to target other corridors, terrains or features and to set up a prioritized target list for end condition solutions on 
terrains, corridors or features. 

b. Search for Template Points

c. To Create Point Controls

8. Multiple template drops be assigned to a corridor.

a. True 

b. False

9. When would you create a Secondary Alignment?

a. When you need to make your template follow edge of pavement geometry. 

b. If you need to change the direction of template processing.

c. When you add edge of pavement geometry as a corridor reference.

10. Edited Template Drops are stored in the corridor by default.

a. True 

b. False
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Summary

Corridor Modeling allows the user to create a dynamic, intelligent and powerful 3D model of their design. The 3D model is then used to create 
cross sections, terrain models and generate corridor quantities. A corridor is created first in 2D by assigning a horizontal and vertical 
alignment to the corridor and then assigning a template to the corridor at a defined interval along the horizontal alignment. Once the template 
is assigned to the corridor a 3D model is created. 

In this course, you learned how to create a corridor for a road and select a feature definition to control the display and accuracy of the corridor. 
You assigned multiple template drops to the corridor and used corridor reference elements. You learned how to add template drops and 
transition the curb height. You added right turn lanes, which required additional template drops. And finally, you learned how to interact with 
other corridors within a project.
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